Version
menu_open
Target Platform(s):

◆ AkAudioAPI

enum AkAudioAPI

< API used for audio output Use with AkPlatformInitSettings to select the API used for audio output.
Use AkAPI_Default, it will select the more appropriate API depending on the computer's capabilities. Other values should be used for testing purposes.

See also
AK::SoundEngine::Init
Enumerator
AkAudioAPI_AAudio 

Use AAudio (lower latency, available only for Android 8.1 or above)

AkAudioAPI_OpenSL_ES 

Use OpenSL ES (older API, compatible with all Android devices)

AkAudioAPI_Default 

Default value, will select the more appropriate API (AAudio for compatible devices, OpenSL for others)

AkAudioAPI_AVAudioEngine 

Use AVFoundation framework (modern, has more capabilities, not available for iOS/tvOS 12 or below)

AkAudioAPI_AudioUnit 

Use AudioUnit framework (basic functionality, compatible with all iOS devices)

AkAudioAPI_Default 

Default value, will select the more appropriate API (AVAudioEngine for compatible devices, AudioUnit for others)

AkAudioAPI_AVAudioEngine 

Use AVFoundation framework (modern, has more capabilities, available only for macOS 10.15 or above)

AkAudioAPI_AudioUnit 

Use AudioUnit framework (basic functionality, compatible with all macOS devices)

AkAudioAPI_Default 

Default value, will select the more appropriate API (AVAudioEngine for compatible devices, AudioUnit for others)

AkAPI_PulseAudio 

Use PulseAudio (this is the preferred API on Linux)

AkAPI_ALSA 

Use ALSA.

AkAPI_Default 

Default value, will select the more appropriate API.

Definition at line 44 of file AkAndroidSoundEngine.h.


Was this page helpful?

Need Support?

Questions? Problems? Need more info? Contact us, and we can help!

Visit our Support page

Tell us about your project. We're here to help.

Register your project and we'll help you get started with no strings attached!

Get started with Wwise