Table of Contents

Wwise Unity Integration Documentation
Release Notes - Wwise Unity Integration 2019.1.9.7221.1704

This release delivers the Wwise SDK update for Wwise 2019.1.9.

Compatibility:

  • Wwise SDK: 2019.1.9
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2 (Personal or Pro).
    Note: Important note: This integration does not support Unity 4. Compatibility with Unity versions not listed above is not guaranteed.
Platforms: Wwise Unity Integration tested on:
Android
iOS
Linux
Mac
Magic Leap (Lumin OS)
PS4
Switch
Stadia
tvOS
UWP (Universal Windows Platform)
Windows
Xbox One
Unity 2019.3.0f10

Resolved Issues:

  • WG-47349 Fixed: Wwise Picker colors in Unity 2019.3 are not the same as in Unity 2019.2.
  • WG-47578 Fixed: Hang when starting Unity from a command line.
  • WG-48108 Fixed: Potential hang when generating a large number of callbacks.
  • WG-48709 Fixed: Hang when integrating Wwise into a Unity project using Asset Pipeline version 2.
  • WG-48831 Fixed: Wwise plug-in not registered in built games.