Wwise Version
arrow_right Table of Contents
Wwise Unreal Integration Documentation
Release Notes 2019.2.0.7216.1583

Each version of this integration matches a specific build of Unreal Engine 4. Here is what has changed in the 2019.2.0.7216.1583 release of the integration.

Important Migration Notes 2019.2.0.7216.1583

Note:
This integration does not support experimental Unreal Engine 4 features.
Note:
This integration compiles against Unreal Engine versions 4.23 and up, but was only tested against Unreal Engine 4.24.

Known Issues

Unreal Engine 4.23/4.24 - Wwise 2019.2.0.7216.1583

  • WG-34431 It is now possible to use shared libraries in all supported Unreal platforms.
  • WG-34896 (WAAPI) Removed the SoundFrame dependency.
  • WG-42515 Updated the Unreal Spatial Audio Integration following API changes.
  • WG-42760 (Spatial Audio) Unreal AkRoomComponent now supports room tones:

    There is now a new Unreal component for Spatial Audio Geometry called AkGeometryComponent, which can be applied to StaticMeshComponents. The AkGeometryComponent sends the StaticMeshComponent's mesh to Spatial Audio.

  • WG-44742 Updated the range limits for Spatial Audio settings in Unreal and Unity.
  • WG-45586 Added the bEnableDirectPathDiffraction parameter to Spatial Audio, in order to globally enable or disable the diffraction.
  • WG-46105 This integration compiles using Unreal Engine version 4.21 and above, though it was only tested with Unreal Engine 4.23.
  • WG-47309 Fixed: Possible crash when changing an AkAudioEvent associated with a Sequencer section, using the macOS Editor.