Target Platform(s):
Wwise SDK 2019.2.13
Linux-Specific Information

This page contains information that is specific to using the Wwise SDK for the Linux platform.

Dependencies for building on Linux

To build on Linux, you will typically need clang, g++ (for libstdc++) and make. On a Debian-based distribution, such as Ubuntu, those packages can be installed by running the following terminal command:

sudo apt install make clang g++

When using wp.py to build plug-ins on Linux, you can use either python or python3. Make sure to install the required packages as described in wp.py First-time Setup.

If you are cross-compiling to 32-bit from a 64-bit system, you will also need to install the g++ multilib package. On a Debian-based distribution, you can install it by running:

sudo apt install g++-multilib

Building SDK samples and source code

Generic makefiles are provided; some environment variables must be defined to build for a given target. Here are the settings to use for various targets:

  • Linux_x32 (Intel x86 32-bits)
    • AK_LINUX_ARCH=x32
    • CFLAGS=-msse2
  • Linux_x64 (Intel x86 64-bits)
    • AK_LINUX_ARCH=x64
  • Linux_armeabi-v6-hf (Raspberry Pi)
    • AK_LINUX_ARCH=armeabi-v6-hf

Additionally, the config environment variable can be set to debug, profile, or release to select the corresponding build configuration; if not specified, the debug configuration will be used.

Note: When using wp.py for building plug-ins on Linux, the configuration can be specified using the -c argument instead.

Linux-Specific AkPlatformInitSettings

Linux Release Notes