Table of Contents

Wwise System Requirements

Before you install Wwise, you should verify its minimum system requirements. The following table describes the hardware and software requirements to install and run the Wwise authoring application.

System Component

Requirement

Processor

The following processors are required to run Wwise:

  • Pentium 4® Processor 3.0 GHz or better with Hyper-Threading technology

  • AMD Athlon 3.0 GHz or better

Operating System

The following operating systems are supported:

  • Windows 7 with SP 1 or more recent

  • Mac OS X Yosemite (10.10) or more recent

    [Note] Note

    For the Wwise sound engine alone, Mac OS X Mavericks (10.9) is also supported.

The Wwise authoring application is only available in 64 bits.

Memory

1 GB of RAM

[Note] Note
Large projects require larger amounts of RAM. Use the 64-bit version of the Wwise authoring application to use more than 3 GB of RAM.

Resolution

The factory layouts have been optimized for monitors with a resolution of 1920 x 1080, but they can be adapted for other resolutions. Support for 4k or 5k is available by enabling the Enable High DPI support User Preferences option.

PDF Reader

A reasonably recent version of Adobe Reader or other PDF reader is required to open the PDF files that are distributed with Wwise.

QuickTime

AAC conversion in Wwise for the Mac® and iOS platforms requires QuickTime 7.6.5 or later.

Mandatory Code Dependencies

Microsoft .NET Framework

Microsoft .NET Framework v4.
The Wwise Launcher will, as needed, automatically install this component before installing a version of Wwise. If, however, you deploy Wwise without using the Launcher (via Perforce or some other revision control system), in order to run the File Packager you will need to install the .NET Framework manually using Microsoft .NET 4 (Web Installer) from the Microsoft website.

Microsoft DirectX®

DirectX June 2010 runtime.
The Launcher will automatically detect if this external component is on your system and, if not, will install it before installing Wwise. If, however, you deploy Wwise without using the Launcher (via Perforce or some other revision control system), you will need to update the DirectX runtime manually. You can do that by downloading it directly from the Microsoft Download Center .

[Note] Note

Without the appropriate DirectX version on your computer, Wwise will run normally; but, the Game Object 3D Viewer will not be available and you may not be able to test Motion in Wwise.

Microsoft Visual Studio Redistributable

The following redistributables must be installed to run the Wwise authoring tool:

  • Microsoft Visual C++ Redistributable Package for Visual Studio 2013 (64-bit)
  • Microsoft Visual C++ Redistributable Package for Visual Studio 2015 (64-bit)

The Launcher will automatically detect if these are on your system and, if not, will install them before installing Wwise.

[Note] Be Sure to Install All the Mandatory Code Dependencies

It is not uncommon for a crash to occur due to one or multiple missing dependencies when installing Wwise without the Launcher. The required dependencies are detailed in the following rows of the Wwise System Requirements table: Microsoft .NET Framework, Microsoft DirectX, and Microsoft Visual Studio Redistributable. Installing the Authoring tool through the Launcher is less troublesome because you don't have to worry about the dependencies since they are automatically provided.