Table of Contents

Warning : Some protected information on this page is not displayed.
Ensure you are logged in if you are a licensed user for specific platforms.
Wwise Unity Integration Documentation
Troubleshooting

Wwise Components/Types show stale or inconsistent data

If you notice Wwise Components, such as AkAmbient or AkState, lose references to their Wwise object, you may have added AkWwiseProjectData.asset to version control. If AkWwiseProjectData.asset is locked, such as often is the case when under version control, new files will be created of the form AkWwiseProjectData##.asset. If this occurs, delete all of them, then click Auto populate in the Wwise Picker to regenerate the file.

Note: Do not keep AkWwiseProjectData.asset under version control! This is a temporary cache file for the Wwise project data, so as to avoid having the Wwise Picker continuously parse the Work Unit files.

Compiling errors after installation

If you have just upgraded Wwise from a previous version, you may have duplicate scripts. In version 2013.2.8, the UNITY_PROJECT_ROOT\Assets\Wwise\Deployment\Examples folder was renamed to Components. If you haven't made any changes to the scripts in the Examples folder, you can simply delete it.

Also, if you develop on multiple platforms, make sure that you have installed the UnityPackage for each of your development platforms. There are some scripts that are platform-specific.

DllNotFoundException in the Unity console

If you see a DllNotFoundException message about AkSoundEngine in the Unity console on Windows, this can be caused by two missing dependencies:

  • Make sure you have DirectX installed on your machine.
  • If you are using the Debug config of the Wwise-Unity Integration, you also need the Microsoft Visual Studio 2010 Debug Redistributables installed. Normally, the Profile configuration is installed by default, so this should not be an issue unless you manually installed the Debug config.

There is no sound

If you hear no sound in your game, check the following:

  • If there is no sound when you run the game in standalone, try to run your game in the Editor on Windows or Mac. It is easier to fix the issues in the editor first.
  • Ensure your SoundBanks have been properly generated, and that Unity can find them. If you are running the game in the editor, the integration will look for the SoundBanks in the Generated SoundBanks path from your Wwise project. If none are found there, it will then look in the StreamingAssets folder. Note that if you chose to override the project SoundBank path in Wwise, the integration will not be able to load them automatically. For more information on the issue, see Build your Unity Game for a Target Platform
  • Ensure that the Sound Engine is initialized properly before any other audio calls are made, and terminated after all engine calls are completed. You need to ensure the Script Execution Order (menu Edit > Project Settings > Script Execution Order) is properly set for AkInitializer.
  • Make sure there are no errors reported in the Unity console.
  • If you connect the Wwise Profiler (F7, in Wwise) while running your game, are there errors reported in the Capture Log?
  • In the Wwise Profiler, in the SoundBank tab can you see your bank(s) loaded? If the tab is not visible, open the Profiling Settings (Alt-G) and enable the SoundBanks. If they are not loaded, you should check when and how you load them. Look for AkBank components and AkSoundEngine.LoadBank calls.
  • In the Wwise Profiler, in the Capture Log, can you see your expected Event posted? If not, you should check that your SoundBanks contain these Events and that they are properly loaded (see previous point). If the banks are loaded, you should check the AkEvent, AkAmbient components and AkSoundEngine.PostEvent calls in your game scripts.

Can't connect the Wwise Profiler

If your game is running on Windows, check the following:

  • Verify that the Run in background setting is enabled in Unity (menu File > Build Settings > Player Settings).
  • Verify that the firewall on your machine allows port 24024 and that Wwise is set as an exception. If the firewall is disabled it is not an issue.
  • Which configuration of the Wwise-Unity Plug-in are you running? Only Debug and Profile have the communication code enabled.
  • Open the Task Manager, kill any process named "adb.exe". This is the Android driver and it locks TCP ports. This is true even if you don't develop on Android or have any Android device connected. (This is an issue on Google's side.)

If your game is running on another computer or console, check the following:

  • Are your Wwise computer and game console on the same subnet? If not, the game will not appear in the Remote Connection dialog. Enter the IP manually with the Connect To IP button.
  • Is your network allowing traffic on port 24024 or dynamic port allocations?

Error during installation - Access to the path is denied in the Unity console

If you see a Wwise: Error during installation: Access to the path is denied message in the Unity console, check the following:

  • Did you try to install a new Plug-in configuration (Debug, Profile, Release) from the Assets > Wwise > Install Plugins menu right after:
    • installing the new Unity Integration from the Wwise Setup window?
    • previewing a Scene in the Unity Editor?
  • Reopen your Unity project and install the new Plug-in configuration (Debug, Profile, Release) right away.

Error during SoundBank generation on Wwise for Mac - Cannot write to Wwise_IDs.h

If, using Wwise for Mac, you see an error during SoundBank generation about not being able to write to Wwise_IDs.h, check the following:

  • Open the Wwise project.
  • In the project settings, go to the SoundBanks tab.
  • Set the Header file path to where the SoundBanks are generated.

Error: Plugin Not Registered

Your Wwise project uses a licensed plug-in which hasn't been included yet in your AkSoundEngine dynamic library. See Adding Plug-ins.

"Multiple plugins with the same name" in the Unity Console on Mac

Using Unity for Mac, upon importing the Integration, the Unity Console might display many errors that say:

Multiple plug-ins with the same name 'aksoundengine' (found at 'Assets/Wwise/Deployment/Plugins/Mac/Release/AkSoundEngine.bundle' and 'Assets/Wwise/Deployment/Plugins/Mac/Debug/AkSoundEngine.bundle'). That means one or more plug-ins are set to be compatible with Editor. Only one plug-in at a time can be used by Editor.

These errors can be safely ignored, as the installation process will properly activate the correct plug-ins.

Unable to integrate or migrate Wwise in a project with Google Play Services installed

The Wwise Launcher will fail to integrate Wwise into or migrate Wwise in a Unity project that has Google Play Services installed when the build target is set to Android. To workaround this limitation, open the Unity project, set the build target to a non-Android platform, close Unity, and restart the integration or migration via the Launcher.