Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Wwise authorin app Mac not working

+1 vote
The authoring app on Mac OS X stopped working. It keep showing a popup saying that there's some problem. I've even tried 4 different builds and the latest from 2014.

Any idea?
asked Nov 4, 2015 in General Discussion by Samuele D. (220 points)
can you show the actual error?
http://cl.ly/image/351S1k2i0T1u this is the popup.
it says: ask the developer if Wwise works with this osx version, you might need to reinstall the app. Also check and install all the avaiable updates.

Needles to say that I've all the recomended updates for OS X Yosemite
When you click Resoconto, can you copy paste any details about the problem? Thank you!
Process:               Wwise [1996]
Path:                  /Users/USER/Downloads/Wwise.app/Contents/MacOS/Wwise
Identifier:            com.codeweavers.Wwise
Version:               ???
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           Wwise [1996]
User ID:               501

Date/Time:             2015-11-04 15:40:52.210 +0100
OS Version:            Mac OS X 10.10.5 (14F1021)
Report Version:        11
Anonymous UUID:        2026237B-CE4C-01D0-6C6E-0197382FE055

Sleep/Wake UUID:       8216BD19-FACB-4F4C-BBBE-8C77D40F2EAB

Time Awake Since Boot: 8300 seconds
Time Since Wake:       710 seconds

Crashed Thread:        0

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /System/Library/Frameworks/Python.framework/Versions/2.6/Python
  Referenced from: /Users/USER/Downloads/Wwise.app/Contents/MacOS/Wwise
  Reason: image not found

Binary Images:
0x8fe15000 - 0x8fe48dd3  dyld (353.2.3) <2DB428B9-7749-3455-B87D-323F61131929> /usr/lib/dyld
0x925cc000 - 0x931f8fff  com.apple.AppKit (6.9 - 1348.17) <1D891DC4-4E22-30FD-A8AC-1221531BEEA3> /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x95506000 - 0x9557cfff  com.apple.securityfoundation (6.0 - 55126) <AE1C6B08-DA73-3F0A-A960-3FED34E77643> /System/Library/Frameworks/SecurityFoundation.framework/Versions/A/SecurityFoundation
0x967e4000 - 0x967e4fff  com.apple.Cocoa (6.8 - 21) <6AF80DDB-C28E-36FF-BC11-D7D561AC52A9> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x9683c000 - 0x96ac6ff3  com.apple.security (7.0 - 57031.40.7) <AAD066B4-AEE9-301A-A258-F114D13331A1> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x96adb000 - 0x96adbfff  com.apple.Carbon (154 - 157) <CA90E930-DE59-3AD9-B158-3A940BA1FA8A> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
0x96c22000 - 0x96c2bfff  com.apple.DiskArbitration (2.6 - 2.6) <D906604A-1D8C-31BF-8F22-EA219FFC858F> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x982f5000 - 0x98372ff3  com.apple.framework.IOKit (2.0.2 - 1050.20.2) <84299E45-C5F3-365F-AC1B-0EAFF8057112> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x992b0000 - 0x992b0fff  com.apple.ApplicationServices (48 - 48) <76C301A4-705B-33DE-BA11-C89DCF1EDCDD> /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices
0x99448000 - 0x9949dff3  com.apple.audio.CoreAudio (4.3.0 - 4.3.0) <C09B57A4-83B8-389C-8B3F-1ECBBB5052C1> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio
0x9975e000 - 0x997ddfff  com.apple.SystemConfiguration (1.14.4 - 1.14) <796BBD68-8E23-32BF-93DD-9C0EA21DB81B> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x99e26000 - 0x99e26fff  com.apple.Accelerate (1.10 - Accelerate 1.10) <C2367B5B-AE20-3084-A864-104743BE478E> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
0x9bebb000 - 0x9c156ffb  com.apple.WebKit (10600 - 10600.8.9) <4EEB0F01-22A2-3C02-989A-ACAE08D72862> /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit
0x9c15b000 - 0x9c169ff3  com.apple.opengl (11.1.3 - 11.1.3) <604B3989-B01E-3ECE-AAAC-A011C7F0A83C> /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL

could it be an error on loading python?
still not working....some help?
Tried to reinstall it again, now says

CrossOver can't initialize a critical component.

Failed to import cxutils module into Python.  See console for errors.

1 Answer

0 votes
 
Best answer
The python error was the cause of my problems.

Actually Wwise, on startup, loads the python directory for a CrossOver component (if it's correct), but the explicit version needs to be the python 2.6. On my machine I was woking only with the 2.7. I reinstalled OS X yosemite with all the python system versions and now it works.

Just remeber that the python located in /System/Library/Frameworks/Python.framework is the system one and so you must never touch that. All your second installation goes to /Library/Frameworks/python.framework and you must refer to this folder for any further python install/unistall

Hope this could help
answered Nov 9, 2015 by Samuele D. (220 points)
selected Nov 9, 2015 by Bernard R. (Audiokinetic)
Thanks Samuele. Do you know why Python 2.6 was not installed at first?
Actually I don't know. It might even be my fault, but I'm not sure
...