Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

"Sound could not find a path to an output device, will use virtual voice setting." when NOT using Rift

+2 votes
Quite inexplicably, all sounds in my game (Unreal Engine 4.15) start producing the notification that "Sound could not find a path to an output device, will use virtual voice setting.", and are will not play (or at least, not audibly) if I don't have the Rift headset in use.

When I put it on/take it off, it notifies me of the audio thread being resumed/suspended respectively, and resumes/interrupts the audio accordingly.

Anyway know how to make it behave in such a way that I can audition my game even without the Rift headset on?
asked Sep 18, 2017 in General Discussion by Chris P. (330 points)
edited Sep 18, 2017 by Chris P.
Hi there, I was curious if you ever found a solution to this issue? I am having a similar one, but with Unity
'fraid not, Blake!

I'm still wondering if this will ever get an answer, but perhaps by chiming in it's being bumped to the top of the stack and will get another shot at being answered. Cheers!
Hi there Chris,

I figured out the issue for my situation, which was actually not an issue with Wwise at all but with SteamVR trying to reset all my audio devices on my machine when launched. The fix for me was - in Unity - setting my script execution order to make sure AKInitializer.cs came before any SteamVR or OpenVR scripts had a chance to execute. Or, I could make my previously broken builds work by setting my desired output device to be set on launch and on close in the SteamVR app. Hope this helps you out as well!

Please sign-in or register to answer this question.

...