Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Unity and Xbox One Build Wwise: APU heap has already been allocated.

+1 vote
I am receiving this error messages after deploying an Xbox One Push Build;

Build crashes as soon as it starts to initialize Wwise plugin.

Wwise: APU heap has already been allocated.
Stacktrace is not supported on this platform.
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
Wwise: Cannot initialize sound engine.
Stacktrace is not supported on this platform.
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
WwiseUnity: Failed to initialize the sound engine. Abort.
Stacktrace is not supported on this platform.

Wwise: Term() called before successful initialization.
Stacktrace is not supported on this platform.
(Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)
asked Dec 3, 2018 in General Discussion by Steffano C. (140 points)
We're also getting the exact same issue. Wwise works fine on other platforms, only Xbox is having this problem.

Unity 2018.2.17f1
Wwise 2018.1.3.6784

Wwise: APU heap has already been allocated.
AkSoundEnginePINVOKE:CSharp_Init(IntPtr)
AkSoundEngine:Init(AkInitializationSettings)
AkWwiseInitializationSettings:InitializeSoundEngine()
AkSoundEngineController:Init(AkInitializer)
AkInitializer:OnEnable()

Wwise: Cannot initialize sound engine.
AkSoundEnginePINVOKE:CSharp_Init(IntPtr)
AkSoundEngine:Init(AkInitializationSettings)
AkWwiseInitializationSettings:InitializeSoundEngine()
AkSoundEngineController:Init(AkInitializer)
AkInitializer:OnEnable()

WwiseUnity: Failed to initialize the sound engine. Abort.
UnityEngine.Debug:LogError(Object)
AkWwiseInitializationSettings:InitializeSoundEngine()
AkSoundEngineController:Init(AkInitializer)
AkInitializer:OnEnable()

Wwise: Term() called before successful initialization.
AkSoundEnginePINVOKE:CSharp_Term()
AkSoundEngine:Term()
AkWwiseInitializationSettings:InitializeSoundEngine()
AkSoundEngineController:Init(AkInitializer)
AkInitializer:OnEnable()

1 Answer

0 votes
 
Best answer
So, not sure if it will help someone in the future or not, but for us it was Unity's default sound engine that was not disabled in the project settings / audio section (you have to check the 'disable' check box)

Cheers
answered Aug 20 by michel s. (440 points)
selected Aug 21 by Mathieu J. (Audiokinetic)
...