Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Running the Cube Demo - SDL2 not detected

0 votes

Setup : MacBook Pro Mid 2012 running Mojave 10.14.6

I've installed Wwise and the Wwise Launcher as well as the sample "Cube" as directed on this page https://www.audiokinetic.com/courses/wwise101/?source=wwise101&id=installing_wwise#read

When attempting to run Cube, error message: The SDL2 library is not detected. The Cube Demo for Mac requires SDL2 to be installed accordingly to the instructions at https://www.audiokinetic.com/library/2019.1.3_7048/?source=Cube&id=running_the_cube_demo#install_libSDL2_for_mac. Please restart the Wwise Launcher after the installation is complete.

I installed http://www.libsdl.org/release/SDL2-2.0.3.dmg (the latest libSDL2 Mac OS X Runtime Binaries package)

The ReadMe says to copy the SDL2.framework to /Library/Frameworks

I haven't been able to locate the Frameworks folder and have hit a rut.

Anyone out there know what my problem is ? Thanks !

asked 5 days ago in General Discussion by Emmett H. (140 points)

1 Answer

+1 vote
 
Best answer

Hi Emmett,

Try to locate the Frameworks folder by starting from you Macintosh HD folder / Library / Frameworks.

If you don't see the folder (by the way it's normal with Mojave), try "Shift + Command + G" and tape "~/Library"

 

answered 4 days ago by Raphaël M. (460 points)
selected 4 days ago by Emmett H.
...