Wwise Authoring is currently not compatible with macOS Catalina. We recommend that you remain on the current version of your operating system until further notice.

Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Unreal: AnimNotify_AKEvent Complains There is No AkComponent In Automated Tests

0 votes
The following warnings appear in our logs when running automated tests. They happen because developers are creating test characters and don't add the AK component.

LogBlueprintUserMessages: [AnimNotify_AkEvent_C_3] WARNING: AkComponent has been created in the notify. It will be using default values for all properties.
LogBlueprintUserMessages: [AnimNotify_AkEvent_C_3] WARNING: Should you wish to use different values, please attach an AkComponent to the Test_AI_Character_C_3.CharacterMesh0 SK_Wolf component on the Test_AI_Character3 actor beforehand.

I've added the AK Component with the proper socket after the fact, but the AnimNotify_AkEvent is still complaining. I'm not sure why this is the case.

Should these warnings even be warnings or are they more of an information? Is it bad that the AnimNotify has to create the AKComponent, if not my current plan is to downgrade these from a warning to an info? It only does it on initialization of the character mesh. It seems like wasted time to go and add the AK Components just for automated tests, when the audio doesn't matter for those specific tests.
asked Nov 4 in General Discussion by Megan S. (190 points)
retagged Nov 4 by Megan S.

Please sign-in or register to answer this question.

...