Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

WAAPI: changing color not working - OverrideColor property?

0 votes

I am trying to change the color of some work units via Waapi but i dont succed. I realized when you use the authoring tool a line is added to the wu xlm which sets overridecolor to True. I tried doing it via Waapi like this:

client.call('ak.wwise.core.object.setProperty', {"object": dirty_wus_ids[i],
                                                 "property": "OverrideColor",
                                                "value": True})

 But then i get a message "Property cannot be set". I see that OverrideColor has True in "Read only" here: https://www.audiokinetic.com/library/edge/?source=SDK&id=wwiseobject_workunit.html

Is this just impossible to do with Waapi? Any workaround?

Thx!

 

 

asked Mar 10 in General Discussion by Eduardo B. (160 points)

1 Answer

+1 vote

You can change WObjects.xml and replace the IsVisible for OverrideColor:
C:\Program Files (x86)\Audiokinetic\Wwise 20??.?.?.????\Authoring\Data\WObjects\WObjects.xml

<Property Name="OverrideColor" Type="bool" IsVisible="true" DisplayName="Override Color">

Restart Wwise for the changes to take effect.

answered Mar 11 by Bernard R. (Audiokinetic) (27,640 points)
...