Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

"Could not find plugin dynamic library" How to link statically a wwise library in UE 4.24 ?

0 votes
Hello !
I am using Unreal Engine 4.24 with Wwise 2019.2.1.7250 integrated, and I can't make any of the Wwise native plugins (Wwise RoomVerb, Wwise Delay, Wwise ParametricEQ...etc) work when packaging my project to a .exe.
I got the error messages "Could not find dynamic library" followed by "Plugin not found" for each of the "regular" plugins when I profile the packaged game with Wwise.
In the Audiokinetic docs, it tells that I potentially have to link statically the wwise plugin libraries by including them on the code of the game but I don't have any clue how to do a thing like that on Unreal 4.24. I tried many other solution like clearing the sound data and generate it again. I also tried to not use the event-based-packaging system, but i got the same problem. However, the thing I don't understand very well is that this problem doesn't occur on my other Unreal 4.23 project with Wwise 2019.1.4.7065  integrated. Is this a known bug regarding the 2.1 version ?

Any one had the same issue and could know how to fix it please?

Thank you in advance.
Cheers.
asked May 23 in General Discussion by Simon L. (140 points)

2 Answers

0 votes
Hey Simon,

Could you try disabling the "Split switch container media" in the integration settings, then clear your sound data and regenerate?

Let us know if this helps!
answered May 26 by Mads Maretty S. (Audiokinetic) (4,800 points)
Hi ! Thank you for your answer. I tried what you wrote in a minimal test project (basic blank FPS project from the presets of UE) and unfortunately, I still got the same issue again on the packaged .exe. No plugin found. I tried with another version of wwise and it doesn't work as well. I am starting to think that this is an issue with Unreal 4.24. Problem is, the fairly big project I am working on have to be in 4.24...
Strange!
When running the packaged game, what path do you get after the "Wwise plug-ion DLL path" is posted in the log? Could you tell us what's in that folder?
0 votes
Hello there !
I allowing myself to Up this post, as we didn't find any solutions to the plugins issue when packaging yet and the project needs to be finished in two weeks. Thank you in advance !
Cheers.

Simon L.
answered Jun 2 by Simon L. (140 points)
...