Audiokinetic's Community Q&A is the forum where users can ask and answer questions within the Wwise and Strata communities. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

"Audio File Importer" Bug on Mac

0 votes
Hello,

I sometimes have a recurring problem with Wwise 2021.1.6. I work on a Mac, and I wonder if it's not coming from there....
When I want to import a sound, I drag and drop and sometimes it doesn't work (although it did before). If I try with Shift + I, I arrive on the "Audio File Importer". I select the destination folder and after selecting it, I have a "Windows" window that opens and asks me again where the destination folder is located.... Then, when I click on Add Files, I choose my file but when I click on OK, it does not appear in the Audio File Importer..... impossible to import a sound...
The only solution I found when it does that is to restart Wwise... It's a bit annoying to work like that... sometimes it works, sometimes not...

Is a 100% Mac interface in the planning? I have the impression that these problems are related to the "Wine" freeware which sometimes doesn't work properly ....

There are sometimes other bugs like this, but I can't remember them all

Sincerely,

Théophile Demarcq
asked Mar 2, 2022 in General Discussion by Théophile Demarcq (1,590 points)
recategorized Mar 10, 2022 by Samuel L. (Audiokinetic)
Even restarting Wwise, then restarting the Mac still doesn't work... I don't see a solution and I can't work on it anymore

Do others have this problem?

This is a Mac M1 on Monterey if that helps you find the problem
I got the same problem with my Macbook M1 max .

It seems version 2021.1.7 don't fits for the chips ??I don't truly know .More than that, I can't play or preview any sound files in it.

But if I open up the older version (2019.2.14) it could work properly.
Hmmm, I just managed to do that by removing the accents from the letters. "En français dans le texte, nous avons pleins d'accents et autres symboles..."  ;o)
Did I get lucky?
Check also the paths if they do not contain special symbols

1 Answer

+1 vote
 
Best answer

Hi Théophile, thank you for reporting these issues.

I can reproduce your failure to import issue when using accented text: the file path shows a double ".wav" extension, and this is likely to be the cause of the bug.
I can also reproduce the Windows-style file browser that shows after the macOS native one.

I've logged these bugs in our system as:

  • WG-59100 Mac Authoring: Fail to import audio sources with accented letters
  • WG-59187 Mac Authoring: Audio Files Importer destination browser shows a double Windows dialog

These are currently scheduled for the next patch of 21.1.

Note that you can always submit bug reports through the Wwise Launcher: see Reporting Wwise Bugs.

answered Mar 10, 2022 by Samuel L. (Audiokinetic) (23,320 points)
selected Mar 15, 2022 by Théophile Demarcq
Thank you for the reply
Update on this issue: I have identified the root cause to be in Wine. A workaround can be implemented on our side, but it will unfortunately not make it into 21.1.9. The fix is currently targeted at 21.1.10 and 2019.2.15.
...