目录

平台要求

本页记载用于构建 Wwise 声音引擎不同版本的各种工具的版本。

通用工具

Microsoft Visual Studio 的以下版本用于构建 Wwise 程序库 :

  • Microsoft® Visual Studio 2013: VS2013 Update 5 (12.0.40629.00)
  • Microsoft® Visual Studio 2015: VS2015 Update 3 (14.0.25420.1)
  • Microsoft® Visual Studio 2017: VS2017 (15.6.27428.2043)

您会注意到,对于 Win32 和 x64,Wwise SDK 安装目录带有后缀“_vc”+ 版本编号(例如“_vc140”或“_vc150”):

  • vc120:包含依赖于 CRT DLL 版本 12.0.40629.00 (对应于 Visual Studio 2013 补丁包 8 版本 12.0.40629.00)的 Wwise Debug、Profile 和 Release 版本的库 。
  • vc140:包含依赖于 CRT DLL 版本 14.0.25420.1(对应于 Visual Studio 2015 补丁包 2 版本 14.0.25420.1)的 Wwise Debug、Profile 和 Release 版本的库 。
  • vc150:包含依赖于 CRT DLL 版本 15.0.27004.2010(对应于 Visual Studio 2017 版本 15.0.27004.2010)的 Wwise Debug、Profile 和 Release 版本的库 。

如果您使用 Visual Studio 的不同版本,或者不想让您的游戏依赖于 Visual Studio 2013 Service Pack 2 version 12.0.30501.00 的上述版本,您可以链接到 Debug (StaticCRT)、Profile (StaticCRT) 和 Release (StaticCRT) 文件夹下的库。


Android™

Android

  • Android SDK:对于 32 位,最低 API 14;对于 64 位,最低 API 21。
  • Android SDK 工具: 26.1.1
  • Android NDK: r17b
iOS

iOS/tvOS

  • iOS 部署目标: 8.0
  • iOS SDK: 11.4
  • tvOS 部署目标: 9.2
  • tvOS SDK: 11.4 (tvOS)
  • Xcode®: 9.4.1
Mac OS X

Mac

  • MacOS: v10.9 Mavericks®(最低目标)
  • Xcode®: 9.4.1
  • Mac SDK: OS X 10.13
  • 基于 Intel 的 Mac 64 位(不支持 PowerPC)
Linux

Linux

  • 编译器: Clang 3.8
  • 目标环境: Steam Runtime
Magic Leap

This information cannot be displayed because you are not signed in as a Magic Leap licensed user.

PlayStation®4

This information cannot be displayed because you are not signed in as a PlayStation®4 licensed user.

Nintendo Switch™

This information cannot be displayed because you are not signed in as a Nintendo Switch™ licensed user.

Windows

Windows

  • Microsoft DirectX®: DXSDK_Jun10 (9.29)
    Note.gif
    Note: 如果您有多个版本的 SDK,请确保 DirectX® SDK 的环境变量 DXSDK_DIR 指向正确的目录。
  • Windows Software Development Kit: 10.0
Xbox One

This information cannot be displayed because you are not signed in as a Xbox One licensed user.