目录

版本说明 - Wwise Unity Integration 2013.1

此次发布为 Wwise 2013.1 提供了 Wwise SDK 更新,Android 相关的新功能,和一般的错误修复。

兼容性:

  • Wwise SDK: 2012.2.x, 2013.1
  • Unity: 3.4.x, 3.5.x, 4.x

支持的平台:

  • Windows 8
    • Desktop????
    • 在 Intel 设备上的 Windows Store App,和 ARM 平板电脑
  • Windows(32 位)
  • Windows(64 位)
  • Mac OS X(10.6 和更高版本)
  • iOS
  • Android
  • Xbox360
  • PS3

新功能:

  • Android:SoundBank 现在可以在 Android 应用程序包(apk)中保存,并且可以使用 LoadBank() API 透明地访问。
  • 对 Windows 64 位的支持。
  • 对 Windows 8 的支持。

已解决的问题:

  • WG-22948:在 PS3 上,由听者索引指派错误导致的定位错误。
  • WG-22938:在 Mac OSX 上,Unity Integration 的定位数据无效。
  • WG-22334:Music userCue 名称被错误地以空字符串报告给 Unity。
  • WG-22329:Unity Integration 中,无法 PostEvent() 到全局范围。
  • WG-22255:Unity Android:在切换应用到后台后声音依然存在。
  • WG-22165:3D 定位在 iOS 和 Android 中无法正常工作。
  • WG-21933:AkCallbackManager.cs 无法正确处理浮点的去序列滑。UserCue 名称??
  • WG-21365:Unity iOS:iOS 音频中断事件时不时发生之后,无法听到声音。
  • WG-22533:一些 API 绑定函数不应该有异常处理程序。

改进:

  • Windows 和 Mac 。。。可以在同一个 Unity 工程中共存。
  • 改进了文档的可读性和精确性,并添加了 关于各个平台特定的信息 部分,便于阅读有关平台的信息。
  • 出于可读性考虑,构建日志现在支持安静和详细模式。
  • 现在构建管线检查用户的 Python 版本,会在未更新版本时发出警告。
  • 现在可以直接使用部署脚本将 Integration 复制到 Unity 的工程中。

迁移:

  • 现在需要 Visual Studio 2010 来为 PS3 构建 Integration。
  • 构建脚本不再支持 Python 2.6 和更旧的版本。需要 Python 2.7.x 或者 3.x。
  • 您自己构建 Integration 时,不再需要环境变量 UNITY_PROJECT_ROOT。默认情况下,Integration 不再自动部署到 UNITY_PROJECT_ROOT 指定的文件夹中。详情参见 从源代码构建原生集成插件
  • Android 构建脚本不再部署 PostprocessBuildPlayer 脚本到 Unity 工程中。
  • IntegrationDemo 工程升级为 Unity 4 格式。
Generated at Fri Mar 29 16:14:38 2019 for Wwise Unity Integration by  doxygen 1.6.3