目录

版本说明 - Wwise Unity Integration 2013.2.1

此次发布为 2013.2.1 提供了 Wwise SDK 更新,新功能包括 overhauled distribution,安装和构建经验,和错误修复。

兼容性:

  • Wwise SDK: 2013.2, 2013.2.1
  • Unity:4.x(不再支持 3.x)

支持的平台:

  • Windows 8(Metro)
    • Desktop????
    • 在 Intel 设备上的 Windows Store App,和 ARM 平板电脑
  • Windows
    • 32 位
    • 64 位
  • Mac OS X(10.6 和更高版本)
  • iOS
  • Android
  • Xbox360
  • PS3

新功能:

  • Unity Integration 现在作为一个 Unity 的资源包分发,其中包含目标平台版本和桌面版本。它可以直接导入到一个 Unity 工程中,在 Editor 中和目标设备上都能使用。
  • 在 Unity Editor UI 中添加了一个新的 Wwise 菜单,用于执行以下任务:
    • 安装插件。
    • 重新构建 Integration。
    • 将一个 SoundBank ID C++ header 转换为它的 C# 版本。
  • 运用 Unity 4 的 Scripting Define Symbols 功能,在多架构平台(例如 Windows)上构建和运行应用程序。
  • 一个构建脚本,用于在任何支持的平台上通过命令行重新构建 Integration。
  • 一个简化的定位演示,添加到了 IntegrationDemo。
  • Android:SoundBank 现在可以保存到 Android Expansion Files(OBB)中,也可从中载入。

已解决的问题:

  • WG-23781:库回调不起作用。
  • WG-23734:在 Windows 平台上,标记回调接收到混乱的字符串。
  • WG-23345:在 Unity Editor 中切换到不支持的平台时出现编译错误。
  • WG-23436:Unity:由于 而导致的听者定位错误。
  • WG-23423:Unity 中 GameObjects 的性能问题,与组件访问有关。
  • WG-22533:Unity:一些 API 绑定函数不应该有异常处理程序。

改进:

  • 简化了 iOS 插件的安装和部署。
  • 更新的文档,包含更精确的先决条件和其它说明。

迁移:

Generated at Sat Aug 17 14:25:09 2019 for Wwise Unity Integration by  doxygen 1.6.3