目录

更新/升级 Wwise 集成包版本

Warning.gif
警告:建议
  • Unity 迁移操作是不可逆的。在您继续之前,请确保已经备份了 Unity 工程。
  • 如果 Unity 工程有版本控制,请确保在开始迁移之前 check-out 整个 Unity 工程文件夹。否则,迁移会失败,因为它无法成功地修改文件。
  • 在安装 Wwise 集成之前,需要确保您的 Unity 工程可以成功编译。(出现警告是正常的。)
  • 如果您已经修改了 C++ AkSoundEngine 插件源代码中的 C++ Wwise SDK,请遵循 当您修改了插件的 C++ 代码时,将 Wwise 集成包 更新/升级到一个较新的版本 中列出的指南

这个安装过程假定您已有了一个包含以前的 Wwise 集成包的 Unity 工程。如果想了解新安装,请参阅 第一次安装 Wwise 集成包 页面。与其它的 Unity 插件不同,您需要留下之前安装的 Wwise 集成包,以便升级到新版本。Wwise Launcher 将安装新功能和漏洞修复,然后将先前的 Wwise 集成迁移到新版本。

Warning.gif
警告: 在安装新版本之前,不要删除之前的 Wwise 集成,因为那样的话,您将 Wwise 音频集成到游戏中的所有努力就白费了。

升级过程分 2 步。首先,您需要将 Wwise 工程更新到您希望使用的新版本,然后也要对 Unity 工程升级。

将您的 Wwise 工程更新到新版本

  1. 启动 Wwise,该 Wwise 的版本要匹配您打算在 Unity 中使用的新 Wwise 集成包。
  • 打开 Wwise 工程。
  1. 当提示将您的 Wwise 工程更新到当前版本时,请回答 “Yes” 。
  2. 完成后,确保在更新 Unity 工程之后,重新生成 Wwise SoundBank,以便能继续您的工作。

将您的 Unity 工程更新到新的 Wwise 版本

将 Unity 工程更新到新的 Wwise 版本是由 Wwise Launcher 负责的。

Generated at Thu May 9 21:19:07 2019 for Wwise Unity Integration by  doxygen 1.6.3