Version
menu_open
link
Wwise SDK 2022.1.7
TargetVer.h
Go to the documentation of this file.
1 /*******************************************************************************
2 The content of this file includes portions of the AUDIOKINETIC Wwise Technology
3 released in source code form as part of the SDK installer package.
4 
5 Commercial License Usage
6 
7 Licensees holding valid commercial licenses to the AUDIOKINETIC Wwise Technology
8 may use this file in accordance with the end user license agreement provided
9 with the software or, alternatively, in accordance with the terms contained in a
10 written agreement between you and Audiokinetic Inc.
11 
12 Apache License Usage
13 
14 Alternatively, this file may be used under the Apache License, Version 2.0 (the
15 "Apache License"); you may not use this file except in compliance with the
16 Apache License. You may obtain a copy of the Apache License at
17 http://www.apache.org/licenses/LICENSE-2.0.
18 
19 Unless required by applicable law or agreed to in writing, software distributed
20 under the Apache License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES
21 OR CONDITIONS OF ANY KIND, either express or implied. See the Apache License for
22 the specific language governing permissions and limitations under the License.
23 
24  Copyright (c) 2023 Audiokinetic Inc.
25 *******************************************************************************/
26 
27 /// \file
28 /// Windows target version specification.
29 
30 #pragma once
31 
32 #ifndef NTDDI_VERSION // Specifies that the minimum required platform is Windows 8.0.
33 #define NTDDI_VERSION 0x06020000 // Change this to the appropriate value to target other versions of Windows.
34 #endif
35 
36 #ifndef WINVER // Specifies that the minimum required platform is Windows 8.0.
37 #define WINVER 0x0602 // Change this to the appropriate value to target other versions of Windows.
38 #endif
39 
40 #ifndef _WIN32_WINNT // Specifies that the minimum required platform is Windows 8.0.
41 #define _WIN32_WINNT 0x0602 // Change this to the appropriate value to target other versions of Windows.
42 #endif
43 
44 #ifndef _WIN32_WINDOWS // Specifies that the minimum required platform is Windows Me.
45 #define _WIN32_WINDOWS 0x0490 // This is already the latest possible version on this deprecated value.
46 #endif
47 
48 #ifndef _WIN32_IE // Specifies that the minimum required platform is Internet Explorer 10. (This is conservative but we don't need IE)
49 #define _WIN32_IE 0x0A00 // Change this to the appropriate value to target other versions of IE.
50 #endif

Was this page helpful?

Need Support?

Questions? Problems? Need more info? Contact us, and we can help!

Visit our Support page

Tell us about your project. We're here to help.

Register your project and we'll help you get started with no strings attached!

Get started with Wwise