Audiokinetic's Community Q&A is the forum where users can ask and answer questions within the Wwise and Strata communities. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Cannot open required Wwise Version (2019.1) for Mac Monterey for 301 Certification

+1 vote
Hello,

I am trying to take the Wwise 301 certification course, but every time I try to download the Wwise 2019.1.11.14, I get an error upon opening the program (Wwise has quit unexpectedly). I am using Mac OS Monterey 12.6. How am I supposed to take the course and follow along if I can't download the correct version? Is there another version that will work with the certification? I am able to download and use the correct version of Unity, but Wwise is giving me issues.

Will
asked Oct 17, 2022 in General Discussion by Will H. (140 points)

2 Answers

0 votes

EDIT: This is no longer the case, 2019.1.11 version has been updated to the latest stack to support newer Monterey releases without Python 2.7.
More details can be found in: https://www.audiokinetic.com/qa/11540/wwise-2019-1-11-monterey-support

Hello Will, 

Yes unfortunately Wwise 2019.1 won't work with Monterey. Apple chose to remove a Wwise dependency (Python 2.7) from Monterey, and since we only maintain the two most recent Wwise versions (Wwise 2019.2 + Wwise 2021.1), only they will compatible with Monterey.

Is it possible to use a newer version of Wwise with Wwise-301? 
Yes, it's possible, but not recommended due to some visual differences. Wwise has changed a lot since Wwise 2019.1, but luckily the Wwise-301 certification is mostly about using the integration in Unity, which looks somewhat the same. So if you choose to use a newer Wwise version, keep a sharp eye on the course images so you understand how it would look in a Wwise 2019.1 version. If you choose to use a newer version of Wwise, you can download a newer version of WAG from the launcher too, instead of having to upgrade it yourself.

For Wwise-251 the story is far less accurate with the course content, especially due to the Runtime Management chapter about Memory pools, which has been completely reworked in Wwise 2019.2. So for those doing the Wwise-251 course, use Windows or a non-Monterey Mac for now. 

answered Oct 24, 2022 by Mads Maretty S. (Audiokinetic) (38,280 points)
edited Feb 10, 2023 by Samuel L. (Audiokinetic)
Hi there, thank you for your quick response. I've tried using a new version of Wwise (2019.2 or 2021.1.11) for taking Wwise-301, but still faced 2 issues below:

1) Wise ADVENTURE GAME license is invalid on newer version Wwise.
2) Remote connections status doesn't work as it mention (a different version).

Do you have any suggestions on which newer Wwise version and Adventure game you recommend installing can run Wwise-301, or do I still need to wait until you finish fixing this problem before taking Wwise-301?

Thanks
Hi again. Alright, here are a few quick answers.

1) Licenses work across any version of Wwise. If it doesn't work, try to copy-paste it again, and check that it's not outdated in your website > account > My projects.

2) If Remote Connections doesn't work, it's most often cause the Major versions are not the same. So make sure you've e.g. downloaded Wwise Adventure Game (WAG) 2021.1.0 and opened the Wwise-301 files using Wwise 2021.1.0 or up to 1.3 (not 2021.1.4 or higher, cause there were profiler improvements).

Feel free to use either WAG 2019.2.5, WAG 2021.1.0, or WAG 2022.1.0, BUT keep in mind the higher the version, the more changes have been applied to Wwise. So WAG 2019.2.5 will probably give you the most "similar" experience, if not able to use 2019.1.11
Hi Mads, the issue is the 301-course Download link provided in the lesson, "Wwise-301.zip" is a "v2019.1" version of WAG rather than a higher version WAG, which caused the remote connection didn't work, and report to a different version.

Also, WAG 2019.2 is not for certification and doesn't have Wwise setting in Unity.

Please advice! Thanks, Yiyang
Hello again.
Yes, the Wwise-301 files are from Wwise 2019.1, so you'll need to open them manually in the newer version of Wwise. OR simply use the associated Wwise project with WAG, which is 100% done, so the few "changes" you do in Wwise-301 will already be set.
So yes, there will be compromises by using a newer version, but the alternative is to find a Windows computer or a Mac with a non-Monterey or newer OS.

Yes, it's true that the Wwise settings in 2019.2 were moved. That's one of the few inaccuracies you'll get by using a newer version. But fear not, go to Edit > Project Settings and you'll find the settings at the bottom of the list.
Hello, there seems to be only 2 versions of WAG: 2019.1.11.7296.14, which does not work with Apple M1, and the 2023 version, which is 'not for certification.'
I cannot Remote Connect because 'the version is older' since I am using a newer version of wwise (any version after 2019, since I am on M1 Mac).

There seems to be no way to get a newer version of WAG, so that I can remote connect with Unity and continue my 301 course. This is extremely frustrating. How can I find it? I have 4 version of Wwise downloaded at this point.

I need to know, which version of Wwise, which version of WAG, and which version of Unity do I need to do the 301 course on an M1 mac. Then, where can I find all these versions? As they seem to not appear in my drop down list in the launcher.

I noticed someone mentioned that the 2019.1.11 has been updated to support Monterey, but this does not help me as I am on Ventura.

Thank you for your help! I am eagerly looking to finish this Certification as I do not have much time to dedicate to it going forward!
0 votes
 
Best answer
As of today, 2019.1.11 has been updated to support macOS Monterey and up fixing the aforementioned issue with Python.

More details can be found in https://www.audiokinetic.com/qa/11540/wwise-2019-1-11-monterey-support
answered Feb 10, 2023 by Samuel L. (Audiokinetic) (23,160 points)
...