Audiokinetic's Community Q&A is the forum where users can ask and answer questions within the Wwise and Strata communities. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

macOS Ventura Incompatability - Wise 101 Certification for 2021.1.13.8036 Project Materials

+1 vote

I recently have tried downloading and launching the Wwise 101 Certification Cube files using version 2021.1.13.8036 and whenever I go to "Launch Wwise" or use the "Open in Wwise" nothing happens. I can see "Wwise" appear in the menu bar but the program never actually opens.

Here's what I found through some digging around the AudioKinetic community Q&A, as well as my computer's specs if it helps:

Findings:

  • Some versions of Wwise have been incompatible with the macOS M1 chips, but only a few have been updated. The version needed to work through the certification project materials, 2021.1.13.8036, was not one of them (from what I've seen so far): https://www.audiokinetic.com/qa/10015/wwise-doesnt-open-on-m1-mac
  • I have tried previous and newer versions of the Wwise software. 2021.1.7.7796 sometimes opens after waiting for a few minutes. This version of Wwise cannot open the 2021.1.13.8036 project materials.

 

Mac Specs:

  • 2022 Mac Studio
  • Apple M1 Ultra Chip
  • Ventura 13.4 macOS
  • Python 3.11.3 & framework is installed
  • SDL2.framework is installed


Troubleshooting Steps I Have Tried

  • Using older and newer versions of the Wwise software.
  • Uninstalling and re-installing both the Launcher and the Wwise software.
  • Restarting my computer both before and after re-installing.
  • There was one instance where it managed to open before trying all these troubleshooting steps, but the UI looked like the picture linked here: https://drive.google.com/file/d/1EUQBcH-T6iFMjk1MHQQMe5UbdxbAkL-G/view?usp=sharing


All that being said, please advice on any possible troubleshooting steps or anything else I can try.

asked Jun 1, 2023 in General Discussion by Mike (110 points)

1 Answer

–1 vote

All versions of Wwise following 2021.1.5 have the latest up-to-date package to run on macOS, including on Apple Silicon chips.

The screenshot you linked could hint at a corrupted setup for that compatibility package. I can suggest these additional steps to get back in a working state:

  • Install Wwise in the default location (/Applications/Audiokinetic)
  • Delete the following hidden folder: "$HOME/Library/Application Support/Wwise2019" (which will be recreated the next time Wwise.app is launched)
  • Make sure there is no process called wineserver of wine64-preloader running before Launching Wwise.app (this can be checked in the macOS Activity Monitor app): you can reboot to clear out any previous "zombie" processes

Please report back if you still experience this issue. I could confirm 2021.1.13 ran correctly on a macbook air with M2 chip with Ventura 13.4.

answered Jun 9, 2023 by Samuel L. (Audiokinetic) (23,300 points)
We are aware of an issue on Apple Silicon where the first launch of newly installed Wwise version takes an extraordinary amount of time (~5 min).

This is under investigation, but as a workaround if you leave it running, Wwise should eventually launch. After that, launching Wwise should be fast (5 seconds).
Please report back if, starting with no wine64-preloader processes running, Wwise never opens.
...