Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Cube theme not playing Lesson 6

+2 votes
Hi,

I'm having an issue with tutorial lesson 6, wherein the music will not play at all. All other elements completed in the lesson work as expected, such as reverb zones etc, but no music.  Everything seems to be in order and all events added to the sound bank, correct platform selected, and correct location selected for the sound bank. So i'm out of ideas.

As always, any help greatly appreciated.

Platform - Mac

Wwise version - Latest

 

Thanks,

Peter
asked Sep 7, 2015 in General Discussion by Peter M. (240 points)
I noticed when I run the Cube and connect to the profiler It displays the call “Deprecated call: music fanatic/03_fanatic-tranquility.ogg”  and since the  source sfx that the DCP_Music event is calling for is named “cubetrak.wav”  I thought this might be the problem.  If so how would i go about changing that?  thanks!
After some trial and error I figured a workaround by changing the event for the main theme (heartbeat also) to Map_load, so they both trigger on start as they should. And I've realised the "Deprecated call" is for other levels and their respective music.  However i'm not getting the DCP_Music hook in the profiler when running the cube, and getting "AK Error: Cannot open file: base.bnk"  and "AK Error: Bank Load Failed
"  messages every time.
Same here. Mac, no music in any of the CRAS lessons.
Thanks for confirming its not just me. I should mention for anyone having the same problem and reading this that I've noticed my workaround for the problem has its downsides.

The "Map_load" event triggers the sound over and over (doesn't reset each time you load a new level) This is fine for one shot sounds, but for music and continuous looping sounds  that trigger on startup it doesn't work, as each time you load a level another instance of the sound will trigger over the top of the previous one.
My post above was made before I finished the lessons...so I was at about #5 at that time. When I ran Cube after Lesson 8, and loaded the correct level (Single Player: DCP_the_core/enter) the music appeared to be working correctly.

1 Answer

0 votes
Hi anyone who is looking for an idea I got the music to start using the Spawn_Player event rather than DCP_Music. I used Death_Player event to then stop it or else it will keep playing new instances of itself everytime your respawn. i don't know if this will cause weird stuff to happen in multiplayer or other maps with enemies but it works fine in the minimap test area.
answered 5 days ago by jac g. (180 points)
...