Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

update problem: The namespace `global::' already contains a definition for `AK'

+6 votes

Hello,

I'm updating wwise unity integration from 2016.2.2 to 2017.1.3. After the update, I get this compile error

Assets/Wwise/Deployment/API/Handwritten/WwiseTypes.cs(6,14): error CS0101: The namespace `global::' already contains a definition for `AK'

The conflict come from Wwise_IDs.cs which has 

public class AK
{
    public class EVENTS
    {...}

}

I regenerated the header file Wwise_IDs.h with Wwise 2017.1.3, then regenerated Wwise_IDs.cs with Unity->Assets->Wwise->Convert Wwise SoundBank IDs but the conflict remains. 

What could be the problem?

Thanks

 

asked Oct 25, 2017 in General Discussion by Nam H. (340 points)
I just tested with an empty project with only wwise unity integration along with a new wwise project with a simple event. The bug is still there. The generated Wwise_IDs.cs still has a class called "AK" which is conflicting with namespace AK.Wwise in WwiseTypes.cs. This namespace was not present in the previous version we used.

3 Answers

0 votes
Is there any update on this issue? did you solve it?
answered Jan 5, 2018 by josh m. (150 points)
We ended not upgrading Wwise as it was not urgent and haven't tested newer Wwise since. We have no update on the issue. It seems like a basic issue when trying to use Wwise_IDs.cs with Unity so either we have a silly configuration problem in our project or there's an issue with Wwise Unity integration. Now that I see there's +3 votes, I know we're not the only ones with this problem.
0 votes
Same probelm here with latest wwise/unity integration
answered Jan 19, 2018 by Ruben R. (240 points)
0 votes

The workaround for this is to rename "public class AK" to "namespace AK".

It's supposedly been fixed in Wwise 2017.2.1 Unity integration but I haven't tested it myself. 

answered Feb 11, 2018 by Nam H. (340 points)
...