Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

Why do generated sound banks not work for the rest of my team using perforce?

0 votes

Hi,

I am having an issue where sound banks work perfectly fine for me and all sounds play as intended when listening on my machine, but no one else on my team has audio playing. We are using perforce and working across multiple platforms, some on mac (Including me) and most on PC. 

On my end. 

  • Sound banks are generated in wwise
  • New ak events added and set to be assigned to the proper bank
  • Sound banks are generated for both platforms inside of UE4
  • I push the updated, Akaudiobank file, the bank folder and events folder inside of UE4, and the temp definition file up to perforce.


On my teams end.

  • They have all the ak events, banks and updated temp def file downloaded
  • They can see emitters in level that are set to auto post or triggers as usual
  • They see the events being assigned to the banks as i see on my end.


Bug:
They hear no audio, and every time something tries to call they get an event ID Error.

Additional Info

  • Refreshing all banks does not work for them
  • They can not generate selected banks even with all appropriate perforce files checked out.


Please help!

asked Oct 31 in General Discussion by Timmy S. (170 points)
More info:

LogAkAudio: Error: Selected node not available. Make sure the structure associated to the event is loaded or that the event has been prepared

2 Answers

+1 vote
I have a feeling that you might be using different versions of Wwise. Can you make sure that isn't the issue?
answered Oct 31 by Deepak Chennakkadan (1,740 points)
Looks to be the same version of wwise / Wwise 2017.1.1.6340
0 votes
We had pretty much the same symptoms although in Unity.
"Wwise Project Path" wasn't set properly on some other team members machine.
https://www.audiokinetic.com/library/edge/?source=UE4&id=using__initialsetup.html
Perhaps this applies here to.
answered Nov 1 by Jascha V. (190 points)
...