Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

UE4, play in editor sound works, in packaged project it does not work

+2 votes
Using the latest versions of Unreal Editor (4.18.1), using the latest version of Unity.  I managed to get everything to work in the editor, and the sounds work fine when using play in editor.  Using Visual Studio 2017 for the Toolchain, for a Windows application.

When I package my project, though, it fires up and acts correctly (movement, clicks, etc) but there is zero sound.  If I package a project that does not use Wwise audio and uses UE4 audio, sound works properly.

A few questions - do I need to generate soundbanks from UE4 or in Wwise?

Where should my audio for the game be located?  For example, if I packaged my UE4 project in "D:/AwesomeProject", what would the file path for my sound?  I can find nothing in my project folders that look anything like soundbanks.

I get these warnings:
UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogLinker: Warning: Asset '../../../../../../Users/Lance/Documents/Unreal Projects/DnDMusicBoard/Plugins/Wwise/Content/AnimNotifyRedirectors/AnimNotify_AkEvent.uasset' has been saved with empty engine version. The asset will be loaded but may be incompatible.
UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogLinker: Warning: Asset '../../../../../../Users/Lance/Documents/Unreal Projects/DnDMusicBoard/Plugins/Wwise/Content/S_AkComponent.uasset' has been saved with empty engine version. The asset will be loaded but may be incompatible.
UATHelper: Packaging (Windows (64-bit)):   LogInit: Display: LogLinker: Warning: Asset '../../../../../../Users/Lance/Documents/Unreal Projects/DnDMusicBoard/Plugins/Wwise/Content/AnimNotifyRedirectors/AnimNotify_AkEventByName.uasset' has been saved with empty engine version. The asset will be loaded but may be incompatible.

Unfortunately, I don't know what to do about those warnings or if they have anything to do with my issue.

 

Thanks!
asked Dec 4, 2017 in General Discussion by Lance B. (130 points)

1 Answer

0 votes
I have the exact same problem, did you manage to fix it by now?
answered Feb 1 by Fabian D. (150 points)
I never got it sorted out.  I switched to Unity.

Did you have any luck?  UE4 seems very interesting so I'd like to get back into it and perhaps answer anyone else who comes across this thread with the same issues.
...