Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

Wwise 2017.1.3.6377 cocos2d-x integration

0 votes

Hello 
I have integrated Wwise 2017.1.3.6377 to cocos2d-x, (testing from github and my game project), it is running with win-32. Initialization runs successfully, banks are loaded, but when AK::SoundEngine::PostEvent is sent sounds are not played in none of the tests. While after compilation IntegrationDemo_Windows_vc140 all tests are running successfully. Under debugging parameters m_memSettings, m_stmSettings, m_deviceSettings, m_initSettings, m_platformInitSettings, m_musicInit are checked in both testing versions and are the same. Could you tell me if this is connected with the fact that cocos2d-x is using opengl and IntegrationDemo_Windows_vc140- directx? If detailed information about connection process is needed please let me know I can provide it.

asked Dec 14, 2017 in General Discussion by Vasiliy B. (140 points)
Problem is not in directx because when I set 2015.1.9 build 5624(Stable) all tests ran. Sound is played.

1 Answer

0 votes

when i use 2017.2,

the error  错误    2    error LNK1104: 无法打开文件“AkConvolutionReverbFXFactory.lib”

Have you ever had the same situation?

answered Jan 11 by ranwenlong@126.com v. (140 points)
Yes, i fixed all problems with integration of wwise. If you download github example (it's old version), you can get linker property in IntegrationDemo project and include all needed libs to your project. I think this lib name is AkConvolutionReverbFX.lib in new version wwise
...