Wwise Authoring is currently not compatible with macOS Catalina. We recommend that you remain on the current version of your operating system until further notice.

Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

[Unity] How to play sound on editor mode

+1 vote
Hello, i'm trying to play sound with wwise, while i'm on editor mode.  but my event work well in "play" and not in "editor mode" for the same scene.

 

in editor mode, i get my event on the wwise profiler,  but no sound is played.
asked Nov 9, 2018 in General Discussion by Thibaut G. (110 points)
Could it possibly be a misplaced RTPC? What do you mean by "editor mode"?
i mean, while i'm on the unity editor, but  not in "play" mode,

2 Answers

0 votes
You need to make sure there's the SoundBank GameObject, AkInitializer GameObject and AkSoundListener Object.
answered Sep 27 by Sally P. (340 points)
0 votes
Hey Thibaut,

Where do you have your scene view camera once playing the sound? Once in editor mode, I believe that the scene view camera acts as your listener, so if you are watching the sound's object on too far a distance, the attentuation might make it inaudible.

Is this helpful? or did you already fix it?
answered Oct 1 by Mads Maretty S. (Audiokinetic) (1,420 points)
...