Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

Clipping produces pops instead of expected distortion

0 votes

I just started testing moving a project from FMOD to Wwise and immediately ran into some annoying behavior.  I opened a new and empty project in Wwise with default settings and changed nothing else as far as I know.  Yet, all samples with clipping -- like the one pictured below -- play with a pop at each clipping point instead of just the usual distortion (distortion I don't mind and even want).  What gives?  FMOD has surprisingly incomplete Unity integration -- prompting a move to a new tool... but this, on the other hand, is just really dumbfounding.  It makes me wonder if I'm missing something obvious, or is it that Wwise just wasn't meant to handle distortion like this?  But, that just sounds too stupid to say so I must be missing something.

I've tried dumping the samples and re-importing them.  Same results.  Samples that don't clip play fine.  All samples that clip play with pops.

https://www.dropbox.com/s/q5z5y6lk89suskn/On-0883rpm-4cyl.wav?dl=0

asked Nov 24, 2018 in General Discussion by Matt J. (300 points)
edited Nov 26, 2018 by Matt J.
Can you post one of your sample somewhere so we can have a look?
Hello Matt, can you upload and post a link to one of the wavs that is causing the issue in your project ? thanks !
I updated the question with a link to the wav and tried again to add the image.

1 Answer

+1 vote
 
Best answer

Thanks Matt. We were able to reproduce. We will take a look. It appears the WAV file contains samples outside the valid range.
Do you know which software was used to generate this WAV file?

Please note that this will not occur in the game. If you convert the file (using Convert... in Wwise ) then uncheck the Orignal button in the transport, you will notice the click disappear.

answered Nov 27, 2018 by Bernard R. (Audiokinetic) (26,100 points)
selected Dec 13, 2018 by Matt J.
Glad to know you can reproduce and it wasn't just me.  The WAV was last exported from an Audacity 2.1.3 project.  The last effect applied to it was Amplify with clipping allowed (obviously).  I believe that was to normalize power.  I'll look into Convert and see how I feel about how it affects workflow.
Any update on this?  Is it expected to be fixed?  I have found the "Convert" workaround to be acceptable but it is still more than a little concerning that an audio tool can't play many of my samples the same as in-game without an extra step (more than just the engine audio).
The issue (WG-40566) was scheduled for a point release update.
...