Wwise Authoring is currently not compatible with macOS Catalina. We recommend that you remain on the current version of your operating system until further notice.

Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

How do i get 3d positioning / spatialization to working in UE 4?

0 votes
Hello, i'm having difficulties getting 3D positioning / spatialization to work in UE 4. The WWise plugin automatically registers and adds an AkComponent for the player (using the Player Camera Manager) and makes it a default listener and every tick sets it's position. I have another actor that has it's own AkComponent that on begin play posts an 3D looping event (a fireplace sound). WWise automatically is setting it's position. When i play the game i hear the regular 2D sounds posted using the player's ak component but i can't hear the sound coming from the previously mentioned actor. What am i missing? Thank you :)

 

Edit: I did a few more tests and for some reason i get the sound working when i start a remote connection. I can disconnect afterwards that the sounds will work fine until the next engine restart where i have to do remote connection again. Any idea what could be causing this?
asked Dec 3, 2018 in General Discussion by David P. (110 points)
edited Dec 4, 2018 by David P.

Please sign-in or register to answer this question.

...