Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

"SDL2 not detected" or "SDL2 is Damaged"

0 votes

This isn't new, but I've noticed that when trying to launch Cube Demo, I get an error message on the launch page that reads "The SDL2 library is not detected. The Cube Demo for Mac requires SDL2 to be installed accordingly to the instructions at https://www.audiokinetic.com/library/2019.1.6_7110/?source=Cube&id=running_the_cube_demo#install_libSDL2_for_mac. Please restart the Wwise Launcher after the installation is complete."

 

Apparently this is due to a bug that is affecting the Mac OS Mojave update (which isn't even the newest update). I haven't been able to find any answers from SDL, or AudioKinetic, but I would like to open this forum up for anyone to post any findings or fixes they stumble upon. 

asked Dec 4, 2019 in General Discussion by jonathan r. (110 points)

3 Answers

0 votes
hi, i have the same issue, i've tried downloading homebrew to installd the sdl2 but theres no change, it keep saying on the laucher that the sdl2 its not install and that bumps me up because to complete the course and get the certification is necesary to be able to use the cube game to understand properly the instructions of the course, so can i also have a hand on the same problem as my friend here jonathan, merci!
answered Jan 14 by Emilio P. (140 points)
0 votes

Hi Jonathan,

Have you tried downloading the latest 'stable' version of the SDL framework directly from the SDL website?

I found that downloading the latest version of the dmg underneath the 'Runtime Binaries' and then following the same installation instructions on the Wwise website seemed to work.

Here's the link for the latest SDL framework: https://www.libsdl.org/download-2.0.php 

Hope this is helpful! :)

answered Mar 27 by Beth (480 points)
0 votes

Hi, I think this might be helpful as I saw someone’s response on reddit and it really worked for me!

https://www.reddit.com/r/GameAudio/comments/e6835a/sdl2_library_isnt_being_detected_by_cube_demo/

I put the file in “My username/Library/Frameworks”
But actually it should be put in “Macintosh HD/Library/Frameworks”

answered Apr 25 by Sandidi.C (140 points)
...