Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

WAG can't run playmode in Unity

0 votes

And it said :all compiler errors have to be fixed before you can enter playmode.

Unity version:2018.4.0f1   Wwise version:2019.1.6.7110

Thanks for advising!

asked Dec 29, 2019 in General Discussion by houyu y. (100 points)

2 Answers

0 votes
Hey Houyu

In order to help, I'll need to know what errors you get in the console.
Could I get you to take a screenshot, or copy the text from them inhere?
answered Dec 29, 2019 by Mads Maretty S. (Audiokinetic) (4,260 points)
IOException: Win32 IO returned 234. Path: D:\Program Files (x86)\Audiokinetic\Wwise Adventure Game 2019.1.0.6947\WwiseAdventureGameSource\Library\PackageCache\com.unity.analytics@3.2.2\Tests\Editor\Unity.Analytics.StandardEvents\Unity.Analytics.StandardEvents.EditorTests.asmdef
System.IO.FileStream.get_Length () (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/FileStream.cs:407)
System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/FileStream.cs:340)
System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share)
(wrapper remoting-invoke-with-check) System.IO.FileStream:.ctor (string,System.IO.FileMode,System.IO.FileAccess,System.IO.FileShare)
System.IO.File.OpenRead (System.String path) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/File.cs:363)
System.IO.StreamReader..ctor (System.String path, System.Text.Encoding encoding, Boolean detectEncodingFromByteOrderMarks, Int32 bufferSize) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/StreamReader.cs:167)
System.IO.StreamReader..ctor (System.String path, System.Text.Encoding encoding)
(wrapper remoting-invoke-with-check) System.IO.StreamReader:.ctor (string,System.Text.Encoding)
System.IO.File.ReadAllText (System.String path, System.Text.Encoding encoding) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/File.cs:587)
System.IO.File.ReadAllText (System.String path) (at /Users/builduser/buildslave/mono/build/mcs/class/corlib/System.IO/File.cs:582)
UnityEditor.Scripting.ScriptCompilation.EditorCompilation.LoadCustomScriptAssemblyFromJson (System.String path) (at D:/unity/Editor/Mono/Scripting/ScriptCompilation/EditorCompilation.cs:469)
UnityEditor.Scripting.ScriptCompilation.EditorCompilation.SetAllCustomScriptAssemblyJsons (System.String[] paths) (at D:/unity/Editor/Mono/Scripting/ScriptCompilation/EditorCompilation.cs:687)
UnityEditor.Scripting.ScriptCompilation.EditorCompilationInterface:SetAllCustomScriptAssemblyJsons(String[])
Okay, first off let's do a bit of Unity troubleshooting.
* Try restarting Unity and see if you get the same errors.
* If that doesn't work, close Unity > find the Library folder (located inside your WwiseAdventureGameSource folder, next to the asset folder) > delete it > reopen Unity and let it initialise.
* If that doesn't work, delete the entire WAG project and re-download it again.
Thanks for your advices,but it still doesn't work.
I redownloaded WAG and ran it again,a window came out and warned that the WAG Unity project version is 2017.4.3f1,some files would be updated.
Then I clicked "Yes",and when I pressed Play in Unity,it still showed the same errors.
Could it be the problem of Unity version?
Hmm.... Strange!
Shouldn't be a problem to update WAG, cause then you'd probably get messages about certain properties in scripts being obsolete and such. To me, this looks more like a problem with the Unity Editor, cause none of this is related to Wwise or WAG.
I did a quick research on the forum.unity.com and I suspect that it's because the file paths are too long. Can you try relocating your 'Wwise Adventure Game 2019.1.0.6947' onto an external harddrive or just topmost on your D:\ drive?
I just solved problem by opening the WAG project in Unity 2017.4.30f1.
So I didn't try the method of relocating the WAG path.  :(
But still thanks for your help. :)
0 votes
Same here and resolved by rename the root folder of WAG to "WAG" and worked on Unity 2018.4.14.

Yes, it may be caused by the over-lentgh path string.
answered Feb 8 by 张雁鸣 (140 points)
...