Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Rebuild plugin for UE4.23.1 custom Oculus-provided version

0 votes

Hi,

I have a problem starting the Unreal project in Oculus Quest.

image

First, when I open the Unreal project, I receive a message that says: the wwise plugin was designed for compilation 4.23.0. Do you try to load it anyway? 

and I say yes. 

Then everything works fine until I try to start it in Oculus Quest and then is when the following window appears: the following modules are missing or are built with a different engine version: AkAudio AudiokineticTools Do you want to rebuild them now?

 image

and then another fatal error window appears.

image  

I'm using UE4.23.1 custom Oculus-provided version which is compiled in C ++ and compiled for Vulkan downloaded from the official Oculus website.

I have installed the Wwise plug-in from the Wwise launcher, Unreal Engine and selecting the Unreal project and integrating the plugin in the same way I did in a previous test project in which everything worked perfect even by launching the Oculus Quest.

I think the rebuild of Wwise integration plug-in will be the solution,  but I'm sorry about my ignorance on how to do that.

I would greatly appreciate if someone explaine to me the steps I have to take, because I see this https://www.audiokinetic.com/library/edge/?source=UE4&id=building.html  but I don't know what to do.

Could anyone help me to do that?

Thanks in advance.

asked Mar 1 in General Discussion by Tosom (100 points)
Why has no one answered this?

I've spent the last 4 days hunting for clues on why on earth this happens and there is zero documentation that explains this.

UE 4.24 with latest Wwise build.

Please, I'm begging you Audiokinetic, please help.
No one has managed to solve my problem and I finally had to stop using Wwise in this project because I cannot change the Unreal version and it must be the custom UE4.23.1 version provided by Oculus.

Anyway it would be nice if someone could fix it

Thanks for your interest.

Please sign-in or register to answer this question.

...