Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Problem with disabeling reverb with AK Enviromental in Unity

0 votes

Hello there! I'm new to Wwise and realy facinated with its possibilities. Now i'm examing spatialisation and stucked with one problem.

I made two reverb zones with Ak Environmental component and one transition between them with Environmental Portal (obviosly). But when i go through zone A to B and then exit it, i still hear the reverb from zone B. If i go backwards it's also reverb from B zone. In this zones reverb switching correctly, if i enter each zone separately (including portal) or deleting the portal there is no problem too. It's almost empty scene there are only two objects with environmental component, character controller and two planes with diffrient surfaces. I'm not even sure how to google this issue corectly. Maybe someone can help me with ready decision or just point me in the right direction. Any help will be appreciated.


Thanks! 

asked Apr 26, 2020 in General Discussion by Artyom K. (100 points)

1 Answer

0 votes
I have the exact same problem and have not been able to solve it. I am using the reverb zones without the portal because I am beginning to think it is a bug in Wwise. I am using Unity 2020 1.2, could also be the problem.
answered Feb 8 by Dominik (140 points)
...