Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

UE 4.25.3 unable to build Android as libs are incompatible

+2 votes

Hi,

I'm trying to build Android using 2019.2.4.7329 with UE 4.25.3 but get the following errors:

UATHelper: Packaging (Android (ETC2)):     ld.lld: Plugins/Wwise/ThirdParty/Android_armeabi-v7a/Profile/lib\libAkSoundEngine.a(AkAudioLib.o) is incompatible with aarch64linux
UATHelper: Packaging (Android (ETC2)):     ld.lld: Plugins/Wwise/ThirdParty/Android_armeabi-v7a/Profile/lib\libAkSoundEngine.a(AkLEngine.o) is incompatible with aarch64linux
UATHelper: Packaging (Android (ETC2)):     ld.lld: Plugins/Wwise/ThirdParty/Android_armeabi-v7a/Profile/lib\libAkMemoryMgr.a(AkMemoryMgr.o) is incompatible with aarch64linux
UATHelper: Packaging (Android (ETC2)):     ld.lld: Plugins/Wwise/ThirdParty/Android_armeabi-v7a/Profile/lib\libAkMemoryMgr.a(AkMemoryMgrBase.o) is incompatible with aarch64linux
UATHelper: Packaging (Android (ETC2)):     ld.lld: Plugins/Wwise/ThirdParty/Android_armeabi-v7a/Profile/lib\libAkStreamMgr.a(AkStreamMgr.o) is incompatible with aarch64linux

Is Android supported on UE 4.25.3? If so how do you recommend building Android on UE 4.25.3?

asked Aug 12 in General Discussion by Lewis W. (120 points)

Please sign-in or register to answer this question.

...