Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

"Can't open source or output file"

+1 vote
Hello everyone!

I'm starting to use Wwise in a little project for a GameJam, but I can't solve this problem. When I try to generate a soundbank I get many warnings: "Can't open source or output file". The only reference I've found about this warning says that it appears when the filename path has more than 252 characteres, but that's not my case. Any ideas why this happens?

Thank you very much!
asked Aug 29, 2020 in General Discussion by Pedro A. (110 points)

3 Answers

+1 vote
Hello,

I have the same problem. Did you solve the problem? Do you remember why and how to fix it?

Thank you

Theo
answered Dec 3, 2020 by Théophile Demarcq (710 points)
I'm also dealing with this issue. I can't haven't found much help yet.
Hello
For my part, I changed folder and the access paths were shorter. It is therefore surely the path which should not exceed 252 characters apparently ...
May it be of use to other users!

Théophile
0 votes
I've been dealing with the same issue, and I saw other people that tried shortening the path, and that didn't help.

In my case I can shorten the path to test. And I'm sure that my filename + path is less than 256 characters (I have counted).

Has AudioKinect commented about this somewhere?

Thanks!
answered Feb 3 by Mauricio R. (140 points)
0 votes
Sorry if this was solved or not,

Curious, if your game folder was on an external drive, and what os were you running.

I had the same issue just recently and we determined that it was due to being on an external drive, which caused the problem. Once I moved it from my external to the internal drive on my mac, the soundbank generated fine.

Maybe something for the AudioKinetic guys to look into unless it has been fixed. This was running Mac Mojave, with an external ssd drive, and Wwise 2019.2.8

Thought I would mention it,
answered Apr 2 by Jason T. (140 points)
edited Apr 3 by Jason T.
...