Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Populating Wwise Picker - Parsing work units all the time

+11 votes
Unity Version: 2020.3.0f1

Wwise Integration 2021.1.0.7575.2069

Whenever loading a scene, exiting playmode, recompiling code the "Populating Wwise Picker" loading bar shows up and parses all the work units. It takes about 15-30 seconds each time.

This is extremely tedious as it happens all the time regardless of whether there were any changes made or if the Wwise picker is even open. This seems like a bug and it has been present in previous versions.

How do I prevent the "Populating Wwise Picker" from occurring unless required?
asked Mar 24, 2021 in General Discussion by Chad K. (250 points)
Same thing here, every single day when I add sounds to my Wwise project (even just one or two!!). 20 to 30mn during which I can't use Unity... I wonder what we are doing wrong.
Hey Denys, I've added an answer that should help if its the same issue

2 Answers

+1 vote
Hey Chad,

Did you find a solution to your problem? I have similar problems happening, but only for certain people on the team. Upgrading to the newest version and Unity integration didn't help.
answered May 25, 2021 by M. Riddersholm (230 points)
Hey sorry I've added an answer that should help if its the same issue
–1 vote
 
Best answer

Sorry I didnt update recently. I did end up fixing this after some advice from the wwise team
It ended up being a problem that went unnoticed during an update.

When entering playmode I noticed there was a warning in Unity that led me to the AkWwiseProjectData scriptable object that had lost its reference to the AkWwiseProjectData.cs script.
I fixed the reference (which solved the re-population during scene switches and code recompiles) and I disabled the Auto Populate from the scriptable object which solved the re-population when exiting playmode.

answered Jun 30, 2021 by Chad K. (250 points)
别误导,不是这个问题引起的。是wwise本身的问题,升级到最新的2021.1.9即可解决、反正我是,没有任何额外的代码修改。
...