Audiokinetic's Community Q&A is the forum where users can ask and answer questions within the Wwise and Strata communities. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Resonance and Mastering Suite Plug-in Errors - Wwise + Unity

0 votes

Wwise version: 2021.1.4.7707

Unity version: 2020.3.24f1

I am having multiple errors when trying to use the Google Resonance and Mastering Suite plug-ins, and I'm not sure how to solve them.

 

 

 

Is there a step I've missed with getting these plug-ins working?

asked Feb 2, 2022 in General Discussion by Tom Bennett (240 points)
edited Dec 1, 2023 by Tom Bennett

1 Answer

+2 votes
Make sure you have modified your Unity integration in the Launcher if you have installed the plug-ins after you integrated Wwise into your project.

You can confirm whether the plug-ins are part of your integration by looking at the folder "Assets\Wwise\Deployment\Plugins\Windows\x86_64\DSP": you should have Resonance and MasteringSuite libraries.
answered Feb 2, 2022 by Samuel L. (Audiokinetic) (23,160 points)
Hi Samuel,

Thank you for the response. I've checked the Unity project's Assets folder, but I don't appear to have the Deployment folder in the Assets\Wwise location.

In the Unity tab of the Wwise Launcher, I clicked 'Modify Wwise in Project'.

I then clicked 'Modify Wwise 2021.1.4.7707'.

I made sure Google Resonance and Mastering Suite were enabled on the next screen, and then after proceeding, the 'modify operation completed successfully' text appeared.

I then went back to the Unity tab of the Wwise launcher, and clicked the bottom Modify button. After clicking modify, the applying operation progress bar hung on the creating working copy notice for a long time, before then eventually getting stuck on "Executing Unity to complete the installation" notice (30+ minutes). This operation never completed, and in the end I had to force-quit the Wwise launcher.

A WwiseIntegrationTemp folder was made in the process, but as the 'Executing Unity' progress bar didn't complete, this did not get automatically deleted.

What do I need to try next? I'm really confused and not sure where I'm going wrong
I also have no deployment folder for either Resonance or for Oculus spatializer. I've integrated wwise into my unity project and into wwise authoring but there is no deployment folder in Project/Assets/Wwise. What step and I missing? n?
this is killing me, ever find a solution? (edit: nevermind, the operation finished eventually!)
...