Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

Capture Log filled with: Unknown game object ID

+3 votes
After recent update of my Unity integration I noticed several problems with audio - all environmental sounds collapsed to 0,0 and other problems. In order to figure out what's wrong I started profiling session. And my Capture Log started filling with Unknown game object ID. Make sure the game is registered...

I've commented out all AkSoundEngine calls and removed all objects with AK components in the scenes but still get those errors. This is pretty complex game and it's possible that I missed something but I have no way to figure out what's wrong. There's no information about the function called or anything.

Previous (i.e. 2016.2.0) integration worked fine, at least considering the audible part because I didn't used the profiler with it. The new one is sounding differently and the profiler is almost useless.
asked Dec 21, 2016 in General Discussion by Maciej M. (510 points)
I'm seeing the same problem, so I created a fresh Unity project, integrated it with Wwise, and I'm getting the same error messages and loss of 3D sound localisation.
I'm having the same issue!!

3 Answers

0 votes
I'm having the same issue. Worked fine with the previous integration, updated it and I'm getting my capture log filled with this error.
answered Dec 23, 2016 by Jason F. (140 points)
+1 vote
Sorry about that, a bug was introduced in the latest 2016.2.1 build. A fix will be available very soon. Stay tuned.
answered Jan 5 by Benoit S. (Audiokinetic) (15,840 points)
0 votes
 
Best answer

Today's integration update seems to solve the problems: positional localization is correct and the capture log is not filled with Unknown game object ID error messages anymore.

answered Jan 9 by Maciej M. (510 points)
selected Jan 10 by Fabien B. (Audiokinetic)
...