Please be advised that the Audiokinetic offices will close at 5:00 p.m. EST on December 21st, 2018 for the holiday period, and will reopen on Thursday January 3rd, 2019 at 08:30 a.m. EST. Learn more.

Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

"Operation completed with error" in Unity integration

+4 votes
I'm starting to get into learning Wwise implementation for Unity, and I'm immediately hitting problems with creating the integrated Wwise project. The tail end of my log file looks like:

 

2017-03-22T23:07:37.905Z: Completed integration download, now proceeding to the integration setup...
2017-03-22T23:07:37.906Z: Game integration: Starting install in mode: add
2017-03-22T23:07:37.906Z: Game integration: Pushing progress: Checking for Unity... 50%.
2017-03-22T23:07:37.951Z: Game integration: Pushing progress: Validating project... 52%.
2017-03-22T23:07:38.150Z: Game integration: Pushing progress: Creating backup /Users/galenborson/2d Platformer.bak... 55%.
2017-03-22T23:07:38.397Z: POST(54): https://www.audiokinetic.com/wwise/launcher/?action=log err:null statusCode:200 PROXY: null
2017-03-22T23:07:38.760Z: Game integration: Pushing progress: Locking project... 57%.
2017-03-22T23:07:38.761Z: Game integration: Pushing progress: Creating empty Wwise project... 60%.
2017-03-22T23:07:38.761Z: Game integration: Creating Wwise project /Users/galenborson/2d Platformer/2d Platformer_WwiseProject/2d Platformer_WwiseProject.wproj
2017-03-22T23:07:43.660Z: Game integration: Result output from Wwise:
2017-03-22T23:07:43.660Z:
2017-03-22T23:07:43.660Z:
2017-03-22T23:07:43.661Z: Game integration: Pushing progress: An error occurred during the creation of the new Wwise project.

The backup project was restored successfully. The project which failed was renamed to: /Users/galenborson/2d Platformer.error3 100%.
2017-03-22T23:07:43.779Z: ERROR: Error: An error occurred during the creation of the new Wwise project.

The backup project was restored successfully. The project which failed was renamed to: /Users/galenborson/2d Platformer.error3
2017-03-22T23:07:43.792Z: Tracking: launcher/unity/install/error/
2017-03-22T23:07:44.256Z: POST(55): https://www.audiokinetic.com/wwise/launcher/?action=log err:null statusCode:200 PROXY: null
2017-03-22T23:11:16.151Z: Tracking: launcher/openLog
2017-03-22T23:11:16.678Z: POST(56): https://www.audiokinetic.com/wwise/launcher/?action=log err:null statusCode:200 PROXY: null

 

Anybody know what the issue could be?
asked Mar 22, 2017 in General Discussion by Galen B. (140 points)
Bump.  I have the same issue.

3 Answers

0 votes
Same thing over here.
answered Jan 2 by Benjamin P. (140 points)
0 votes
I'm trying to upgrade my Unity integration from 2016.1.3 to 2017.2.0. Also managing to fail the upgrade process with the same error message. There's a ton of error lines on my log, here's a taste:

From Compiler output section:

Assets/Wwise/Deployment/API/Generated/Common/AkMIDIEvent.cs(52,10): error CS0246: The type or namespace name `AkMIDIEventTypes' could not be found. Are you missing an assembly reference?
Assets/Wwise/Deployment/API/Generated/Common/AkMIDIEvent.cs(61,10): error CS0246: The type or namespace name `AkMIDICcTypes' could not be found. Are you missing an assembly reference?
Assets/Wwise/Deployment/API/Generated/Common/AkMIDIEventCallbackInfo.cs(25,26): error CS0115: `AkMIDIEventCallbackInfo.setCPtr(System.IntPtr)' is marked as an override but no suitable method found to override
Assets/Wwise/Deployment/API/Generated/Common/AkMIDIEventCallbackInfo.cs(34,24): error CS0115: `AkMIDIEventCallbackInfo.Dispose()' is marked as an override but no suitable method found to override

(etc..)

 

Towards the end:

executeMethod class 'WwiseSetupWizard' could not be found.
Argument was -executeMethod WwiseSetupWizard.RunMigrate
 
(Filename: C:\buildslave\unity\build\Runtime/Utilities/Argv.cpp Line: 226)

Failed to redirect stdout (non-fatal)

Aborting batchmode due to failure:
executeMethod class 'WwiseSetupWizard' could not be found.
Argument was -executeMethod WwiseSetupWizard.RunMigrate

Would appreciate any help as my work is pretty much stalled and the rest of the team is eager for the Timeline improvements. I have the entire log saved if you want me to dig up some info.
answered Jan 10 by Simo S. (180 points)
0 votes

TL;DR: Open the Wwise application from the launcher, it will require you to update some Visual Studio stuffs for C++. After that, the Unity integration worked like a charm for me.

I was struggling a bit with this problem, and I suppose people here have found ways to solve it.. but here goes my 5 cents. I tried running as root, tried changing the permissions, but unfortunately the errors being shown does not indicate any problem with the problem at hand. When trying to run the launcher as root, I accidently ran the Wwise app I had installed. I saw it tried to download some stuff but aborted it seeing as I don't want to execute and download stuff as root. 

This sprung the idea to launch the Wwise app to get the necessary dependencies. 

Hope this helps future people.

answered Aug 17 by Max J. (140 points)
...