Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

PostEventAtLocation in Unreal Engine 4.16.3 doesn't work

0 votes

Hi,

We recently upgraded to UE 4.16.3 and wWise 4.17.1.0.6302 and noticed that we got the following logspam in the Unreal Log for each event posted through PostEventAtLocation:

LogAkAudio:Error: Unknown emitter game object ID on event. Make sure the game object is registered before using it and do not use it once it was unregistered.
LogAkAudio:Error: AK::SpatialAudio::RegisterEmitter: game object is not registered.
LogAkAudio:Error: AK::SpatialAudio::SetGameObjectInRoom: game object not registered.

In the wWise log we got the following error message:

A temporary workaround until the audiokinetic team makes a real fix (or is it the real fix?) is injecting the following code after line FAkAudioDevice::PostEventAtLocation:1183 (after const AkGameObjectID objId = (AkGameObjectID)&in_EventName;)

AK::SoundEngine::RegisterGameObj( objId );

Cheers,
Markus

asked Aug 29, 2017 in General Discussion by Markus R. (320 points)

1 Answer

0 votes
Hi Markus, this is a known issue on our end, that will be fixed in 2017.1.1 that will come out this week.
answered Aug 29, 2017 by Fabien B. (Audiokinetic) (12,180 points)
Will this update be in the wWise sound engine or in the engine plugin (or both?)
...