Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

Feature Request(Bug?) Effect Mode does not appear in multi-editor. Images Included

0 votes

The multi-editor is a great tool when combined at queries to make large scale changes to your project. We were using it recently and discovered a quirk that I believe was just an oversight in the UI.

The multi-editor doesn't let you edit the mode setting of an effect. However, it does like to edit Render/Bypass which you edit in the same place. Combined with the fact that mode defaults to "Define Custom" and not "Use Shareset" this makes it a PITA to actually change / setup an effect shareset on a large number of objects. As a workaround, everytime we update the shareset we change every object again but it leads to a lot of churn on the files.

Album: https://imgur.com/a/lOUlJ

asked Dec 5, 2017 in Feature Requests by Brent R. (100 points)

1 Answer

0 votes
You need to right click the effect name box. Should will see the Shareset/Custom options in the menu.
answered Dec 6, 2017 by Bernard R. (Audiokinetic) (22,280 points)
All I see is the option "Set Effect".
The UI does enable you to set the effect to a shareset. However, once you select a shareset you should have two options for mode.
"Define Custom" (Changes to the shareset won't propagate)
"Use Shareset" (Changes to the shareset propagate)

I don't see a way to toggle this specific setting.
https://imgur.com/a/Pqc4E
Hey Bernard, sorry to ping you again but does my comment above make sense?
I'm not seeing the option to set the Shareset Mode anywhere in the multi-editor. Am I just being blind?
you are right, the Custom/Shareset only appear if:
 - 1 object is edited in Multi-Editor
 - all edited objects have the same Shareset

It does not appear if multiple objects are edited with "customs".
...