Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. Contact Sales if your project requires a support plan.

Cube for Mac failed the Build and Run in XCode

+1 vote
I am trying to run Cube on my Mac running OS X 10.6.8 (Snow Leopard) and when trying to build the project within XCode, I am getting an error right away. ! error: There is no SDK wih the name or path 'macosx10.8'. Also XCode is detecting "Base SDK Missing" in it's 'Active Configuration' drop down menu in the upper left corner.

Do I need to run OS X 10.8 to be able to work on Cube?
asked Aug 16, 2014 in General Discussion by Zahari S. (190 points)
edited Oct 2, 2014 by Bernard R. (Audiokinetic)

1 Answer

0 votes
Cube for Mac is now officially supported with Wwise 2014.1.
answered Aug 18, 2014 by Simon A. (Audiokinetic) (3,500 points)
edited Oct 2, 2014 by Bernard R. (Audiokinetic)
I am indeed running Wwise 2014.1 and the associated SDK with it. Yet the Build still failed.
XCode still giving erros when building the Cube project!
Hello

I can't run Cube using terminal so I tried to get the game running using Xcode, I did what the readme/Mac.txt told to do. But I can't find the xcode project at /path/to/CubeDemo/cube_source/src/Mac/CubeMac.xcodeproj

In /path/to/CubeDemo/cube_source/src/ I don't have the /Mac/ folder.

Could you do a step by step on how you opened Cube with Xcode ?

Thanks
...