Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Unreal 4.22 support?

0 votes
What is the timeline for releasing support for Unreal 4.22?
asked Apr 11 in General Discussion by Ben H. (140 points)

1 Answer

+1 vote

This is now available in 2019.1.0.6947.1305

answered Apr 12 by Bernard R. (Audiokinetic) (27,040 points)
Awesome ! Thank you !
Thanks for the tip!

Where can we see that final part of the version number? The installer only seems to show the 6947 version number.
I'm trying to integrate this 4.22 version as an Engine Plug-In into a vanilla PC version of UE4 4.22 and encountering warnings such as:-

AkAudio\AkAudio.Build.cs(436,39): warning CS0618: 'UnrealBuildTool.ModuleRules.UEBuildFramework' is obsolete: 'The UEBuildFramework class has been deprecated in UE 4.22. Please use the Framework class instead.'

And errors such as:-

AkGameplayTypes.h(360) : LogCompile: Error: An explicit Category specifier is required for any property exposed to the editor or Blueprints in an Engine module.

AkAudio/Classes/InitializationSettings/AkInitializationSettings.h(96) : LogCompile: Error: An explicit Category specifier is required for any property exposed to the editor or Blueprints in an Engine module.

Anyone else seeing the same problems?

Ollie
Hi,

I have encountered the same problems and I had posted them here: https://www.audiokinetic.com/qa/5751/xboxone-wwise-2019-6947-unreal-integration-xboxone-problems

No one has never answer to me... Some errors (like #include "Paths.h") are coming from UE4.20 --> UE4.21 migration where some files were moved under Misc/ folder.
But the Category Tag is a big error. Any UPROPERTY exposed to editor by Engine plugins/modules should have one! I simply add it in every line, but I'm waiting for something by Audiokinetic.

I have just downloaded 2019.1.0.6947.1305 (before I was using 1299) to see if something has changed, but those classes are exactly the same.
Beside the problem as above, i also met a crash when launching editor, and i might fixed it but please check it.

Engine\Plugins\Wwise\Source\AudiokineticTools\Private\AkAudioBankGenerationHelpers.cpp

//IProjectManager& ProjectManager = IProjectManager::Get();

//auto& TargetPlatforms = ProjectManager.GetCurrentProject()->TargetPlatforms;

//if (TargetPlatforms.Num() > 0)

//{

// TSet<FString> AvailablePlatforms;

// for (const auto& TargetPlatform : TargetPlatforms)

// {

// AvailablePlatforms.Add(TargetPlatform.ToString());

// }



// auto Intersection = SupportedPlatforms.Intersect(AvailablePlatforms);

// if (Intersection.Num() > 0)

// {

// SupportedPlatforms = Intersection;

// }

//}

TArray<ITargetPlatform*> Platforms = GetTargetPlatformManager()->GetTargetPlatforms();

if (Platforms.Num() > 0)

{

TSet<FString> AvailablePlatforms;

for (ITargetPlatform* CheckPlatform : Platforms)

{

if (CheckPlatform)

{

AvailablePlatforms.Add(*(CheckPlatform->PlatformName()));

}

}

auto Intersection = SupportedPlatforms.Intersect(AvailablePlatforms);

if (Intersection.Num() > 0)

{

SupportedPlatforms = Intersection;

}

}
...