Audiokinetic's Community Q&A is the forum where users can ask and answer questions within the Wwise and Strata communities. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Can't connect Profiler to Unity project unless the game is running

0 votes
Hi folks,

Is there any reason why I can't connect the Profiler to a Unity project unless I'm in Play mode? I know this is possible in the WAG as I've seen it done in the tutorial videos, so I'm assuming it's something I've set up wrong on my end.

Any suggestions are most appreciated.

Simon
asked Sep 30, 2020 in General Discussion by Simon P. (240 points)

1 Answer

0 votes
Hey Simon,

Hmm.. could be a network problem, but first, could you try connecting to this IP - 127.0.0.1? That's your local IP.
answered Sep 30, 2020 by Mads Maretty S. (Audiokinetic) (39,400 points)
Didn't work unfortunately. Just keeps attempting to connect unsuccesfully.
Works fine once I press Play in Unity however.
Hmm... Do you get a "Sound Engine Initialized" when exiting playmode and looking in the console? Or what other messages do you get?
Nothing like "Sound Engine Initialized" no. I get a Wwise: Voice Starvation, and a couple of Event ID not found errors, but that's related to something else.
Sorry for the necro but same issue here.

Wwise -> 2023.1.0.8367.2953

Unity -> 2022.3.5f1

Once I click Play in the Unity Editor, it shows up in Remote Connections but only while the Editor is running.

- Connecting to the localhost IP doesn't work (even w/ port 24024)
- Disabling Firewall
- Trying a different Game Discovery port in both the Wwise and Unity Project Settings
- Killing the adb.exe processes
- Wwise Picker also connects just fine back to the Wwise Editor
...