Community Q&A

Where Wwise users help each other out!

Audiokinetic's Community Q&A is the forum where Wwise users ask and answer questions within the Wwise community. If you would like to get an answer from Audiokinetic's Technical support team, make sure you use the Support Tickets page.

Linker errors in UE4 c++ project

0 votes

HI,

I'm running UE4 version 4.5 and Wwise SDK version 2014.1.1 Build 5179 and I am having linking errors when trying to use the Wwise specific classes in my C++ game project.  Something just as simple as FAkAudioDevice::Get() causes an unresolved external symbol linking error.  I was able to use the suplied Wwise demo project with no problems, but creating my new c++ project I am getting linking errors if I try to use any of the Wwise classes.

 

Error output from Visual Studio:

MyPawn.cpp.obj : error LNK2019: unresolved external symbol "public: static class FAkAudioDevice * __cdecl FAkAudioDevice::Get(void)" (?Get@FAkAudioDevice@@SAPEAV1@XZ) referenced in function "public: void __cdecl AMyPawn::OnMouseClick(void)" (?OnMouseClick@AMyPawn@@QEAAXXZ)
1>C:\Projects\Unreal\Projects\MyProject2\Binaries\Win64\UE4Editor-MyProject2.dll : fatal error LNK1120: 1 unresolved externals


 

Any ideas?

 

Thanks,

Jared

asked Dec 4, 2014 in General Discussion by Jared M. (220 points)
edited Dec 4, 2014 by Jared M.

1 Answer

0 votes
 
Best answer

In your game's build script, make sure you include a dependency on the AkAudio module, as so:

            PublicDependencyModuleNames.Add("AkAudio");

 
answered Dec 8, 2014 by Benoit S. (Audiokinetic) (16,000 points)
selected Dec 8, 2014 by Jared M.
Thanks!  I eventually figured it out but forgot to come back here an post that.

I'm getting another unresolved external symbol linker error trying to use AK::SoundEngine::GetIDFromString(), any help for this one?
...